When attempting to download applications from the Mac App Store, I have found a number (not all, but annoyingly many) simply say "[application name] cannot be installed on this computer" with no explanation. I assume this is because my Macbook Pro is Core Duo and not Core 2 Duo, and the application developers are lazy slugs who haven't compiled their application Universal (IA32 + AMD64). It would be bloody nice if you documented this, if this is the case, and applied a clue bat to the application developers about the existence of 32-bit Macs running Snow Leopard. Thanks ever so much.
Lynx-enhanced by <peter at taronga.com> (Peter da Silva)